Linux出现内核级漏洞

  Linux出现内核级漏洞,攻击者只要通过一个简单的C程序就可利用整个脆弱系统。

ag游戏大厅注册|平台  发现这一漏洞的是挪威的一名研究人员。他在Linuxreviews.org站点上表示,攻击者想要利用上述漏洞需要具有Shell访问或其他上传及运行程序的方法,与cgi-bin和FTP存取相似。然后,运行可以在任何标准用户账户下发挥作用的代码。

  研究人员同时还发表了针对2.4和2.6内核的数个补丁程序,有助于防止该漏洞导致系统崩溃。点击这里可查找到2.4.xx内核补丁,点击这里获取2.6内核补丁。

  据了解,Linux之所以会出现上述漏洞和它的内核信号处理器不能正确处理浮点(FP)例外有关。

  Linux之父Linus Torvalds已承认当存在待解决的FP错误时,Linux内核可能会出现问题。但他认为他已修正了这一问题。

linux



    延伸阅读